#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\sHello\s"
Local $sString = "<some tag> <some_nested_tag attr="Hello"> Text </some_nested_tag> Hello world Hello Programming </some tag>"
Local $sSubst = " HI "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)