package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\sHello\s`)
var str = `<some tag> <some_nested_tag attr="Hello"> Text </some_nested_tag> Hello world Hello Programming </some tag>`
var substitution = " HI "
fmt.Println(re.ReplaceAllString(str, substitution))
}