$re = '/\sHello\s/i';
$str = '<some tag> <some_nested_tag attr="Hello"> Text </some_nested_tag> Hello world Hello Programming </some tag>';
$subst = " HI ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;