use strict;
my $str = '<some tag> <some_nested_tag attr="Hello"> Text </some_nested_tag> Hello world Hello Programming </some tag>';
my $regex = qr/\sHello\s/ip;
my $subst = ' HI ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";