import Foundation
let pattern = #"\sHello\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<some tag> <some_nested_tag attr="Hello"> Text </some_nested_tag> Hello world Hello Programming </some tag>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" HI "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)