using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\sHello\s";
string substitution = @" HI ";
string input = @"<some tag> <some_nested_tag attr=""Hello""> Text </some_nested_tag> Hello world Hello Programming </some tag>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}