const regex = /\sHello\s/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\sHello\\s', 'ig')
const str = `<some tag> <some_nested_tag attr="Hello"> Text </some_nested_tag> Hello world Hello Programming </some tag>`;
const subst = ` HI `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);