package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<pages index="(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\.djvu)" from=(3) to=(8) fromsection= tosection= \/>`)
var str = []byte(`<pages index="La Divina Commedia Napoletano Domenico Jaccarino-Nfierno.djvu" from=3 to=8 fromsection= tosection= />`)
var substitution = []byte("{{Iwpages|old|$1|$2|$3||}}")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}