// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<pages index="(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\.djvu)" from=(3) to=(8) fromsection= tosection= \/>"#).unwrap();
let string = "<pages index=\"La Divina Commedia Napoletano Domenico Jaccarino-Nfierno.djvu\" from=3 to=8 fromsection= tosection= />";
let substitution = "{{Iwpages|old|$1|$2|$3||}}";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}