re = /<pages index="(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\.djvu)" from=(3) to=(8) fromsection= tosection= \/>/
str = '<pages index="La Divina Commedia Napoletano Domenico Jaccarino-Nfierno.djvu" from=3 to=8 fromsection= tosection= />'
subst = '{{Iwpages|old|$1|$2|$3||}}'
result = str.sub(re, subst)
# Print the result of the substitution
puts result