import re
regex = re.compile(r"<pages index=\"(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\.djvu)\" from=(3) to=(8) fromsection= tosection= \/>")
test_str = "<pages index=\"La Divina Commedia Napoletano Domenico Jaccarino-Nfierno.djvu\" from=3 to=8 fromsection= tosection= />"
subst = "{{Iwpages|old|$1|$2|$3||}}"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)