import Foundation
let pattern = #"<pages index="(La Divina Commedia Napoletano Domenico Jaccarino-Nfierno\.djvu)" from=(3) to=(8) fromsection= tosection= \/>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<pages index="La Divina Commedia Napoletano Domenico Jaccarino-Nfierno.djvu" from=3 to=8 fromsection= tosection= />"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{Iwpages|old|$1|$2|$3||}}"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}