# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([{,]\s*)"field\.with\.dots"(\s*:)/$1"field_with_dots"$2/gm;t' <<< "{ \"field.with.dots\": \"\", \"field-with-dots\" : \"field.with.dots\", \"field.with.dots\":\"\" }"