package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([{,]\s*)"field\.with\.dots"(\s*:)`)
var str = `{ "field.with.dots": "", "field-with-dots" : "field.with.dots", "field.with.dots":"" }`
var substitution = "$1"field_with_dots"$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}