// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([{,]\s*)"field\.with\.dots"(\s*:)"#).unwrap();
let string = "{ \"field.with.dots\": \"\", \"field-with-dots\" : \"field.with.dots\", \"field.with.dots\":\"\" }";
let substitution = "$1\"field_with_dots\"$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}