using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([{,]\s*)""field\.with\.dots""(\s*:)";
string substitution = @"$1""field_with_dots""$2";
string input = @"{ ""field.with.dots"": "", ""field-with-dots"" : ""field.with.dots"", ""field.with.dots"":"" }";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}