import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\{,]\\s*)\"field\\.with\\.dots\"(\\s*:)";
final String string = "{ \"field.with.dots\": \"\", \"field-with-dots\" : \"field.with.dots\", \"field.with.dots\":\"\" }";
final String subst = "$1\"field_with_dots\"$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}