use strict;
my $str = '{ "field.with.dots": "", "field-with-dots" : "field.with.dots", "field.with.dots":"" }';
my $regex = qr/([{,]\s*)"field\.with\.dots"(\s*:)/mp;
my $subst = '$1"field_with_dots"$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";