re = /([{,]\s*)"field\.with\.dots"(\s*:)/m
str = '{ "field.with.dots": "", "field-with-dots" : "field.with.dots", "field.with.dots":"" }'
subst = '$1"field_with_dots"$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result