import Foundation
let pattern = #"([{,]\s*)"field\.with\.dots"(\s*:)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{ "field.with.dots": "", "field-with-dots" : "field.with.dots", "field.with.dots":"" }"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"field_with_dots"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)