#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([{,]\s*)"field\.with\.dots"(\s*:)"
Local $sString = "{ "field.with.dots": "", "field-with-dots" : "field.with.dots", "field.with.dots":"" }"
Local $sSubst = "$1"field_with_dots"$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)