$re = '/([{,]\s*)"field\.with\.dots"(\s*:)/m';
$str = '{ "field.with.dots": "", "field-with-dots" : "field.with.dots", "field.with.dots":"" }';
$subst = "$1\"field_with_dots\"$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;