# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^I.*? (?:one|two)( |\b).*$//gm;t' <<< "I dont have any one
We dont have any one
I dont have any more
I dont have any two
Ice one "