const regex = /^I.*? (?:one|two)( |\b).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^I.*? (?:one|two)( |\\b).*$', 'gm')
const str = `I dont have any one
We dont have any one
I dont have any more
I dont have any two
Ice one `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);