import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^I.*? (?:one|two)( |\\b).*$";
final String string = "I dont have any one\n"
+ "We dont have any one\n"
+ "I dont have any more\n"
+ "I dont have any two\n"
+ "Ice one ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}