using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^I.*? (?:one|two)( |\b).*$";
string substitution = @"";
string input = @"I dont have any one
We dont have any one
I dont have any more
I dont have any two
Ice one ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}