$re = '/^I.*? (?:one|two)( |\b).*$/m';
$str = 'I dont have any one
We dont have any one
I dont have any more
I dont have any two
Ice one ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;