use strict;
my $str = 'I dont have any one
We dont have any one
I dont have any more
I dont have any two
Ice one ';
my $regex = qr/^I.*? (?:one|two)( |\b).*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";