package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^I.*? (?:one|two)( |\b).*$`)
var str = `I dont have any one
We dont have any one
I dont have any more
I dont have any two
Ice one `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}