re = /^I.*? (?:one|two)( |\b).*$/m
str = 'I dont have any one
We dont have any one
I dont have any more
I dont have any two
Ice one '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result