#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^I.*? (?:one|two)( |\b).*$"
Local $sString = "I dont have any one" & @CRLF & _
"We dont have any one" & @CRLF & _
"I dont have any more" & @CRLF & _
"I dont have any two" & @CRLF & _
"Ice one "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)