// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^I.*? (?:one|two)( |\b).*$").unwrap();
let string = "I dont have any one
We dont have any one
I dont have any more
I dont have any two
Ice one ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}