# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/102\d2015/10212015/gm;t' <<< "title_10212015_0001.jpg
title_10222015_0002.jpg
title_10232015_0003.jpg
title_10232015_0005.jpg"