// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)102\d2015").unwrap();
let string = "title_10212015_0001.jpg
title_10222015_0002.jpg
title_10232015_0003.jpg
title_10232015_0005.jpg";
let substitution = "10212015";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}