const regex = /102\d2015/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('102\\d2015', 'gm')
const str = `title_10212015_0001.jpg
title_10222015_0002.jpg
title_10232015_0003.jpg
title_10232015_0005.jpg`;
const subst = `10212015`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);