using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"102\d2015";
string substitution = @"10212015";
string input = @"title_10212015_0001.jpg
title_10222015_0002.jpg
title_10232015_0003.jpg
title_10232015_0005.jpg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}