use strict;
my $str = 'title_10212015_0001.jpg
title_10222015_0002.jpg
title_10232015_0003.jpg
title_10232015_0005.jpg';
my $regex = qr/102\d2015/mp;
my $subst = '10212015';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";