#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)102\d2015"
Local $sString = "title_10212015_0001.jpg" & @CRLF & _
"title_10222015_0002.jpg" & @CRLF & _
"title_10232015_0003.jpg" & @CRLF & _
"title_10232015_0005.jpg"
Local $sSubst = "10212015"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)