$re = '/102\d2015/m';
$str = 'title_10212015_0001.jpg
title_10222015_0002.jpg
title_10232015_0003.jpg
title_10232015_0005.jpg';
$subst = "10212015";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;