import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "102\\d2015";
final String string = "title_10212015_0001.jpg\n"
+ "title_10222015_0002.jpg\n"
+ "title_10232015_0003.jpg\n"
+ "title_10232015_0005.jpg";
final String subst = "10212015";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}