re = /102\d2015/m
str = 'title_10212015_0001.jpg
title_10222015_0002.jpg
title_10232015_0003.jpg
title_10232015_0005.jpg'
subst = '10212015'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result