import re
regex = re.compile(r"102\d2015", flags=re.MULTILINE)
test_str = ("title_10212015_0001.jpg\n"
"title_10222015_0002.jpg\n"
"title_10232015_0003.jpg\n"
"title_10232015_0005.jpg")
subst = "10212015"
result = regex.sub(subst, test_str)
if result:
print(result)