package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)\[sometag\](.*?)\[\/sometag\]`)
var str = `[sometag] here is more text
it spans more than one line [/sometag]
[sometag]this is a bit of text[/sometag]`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}