// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)(?s)\[sometag\](.*?)\[\/sometag\]").unwrap();
  let string = "[sometag] here is more text
it spans more than one line [/sometag]
[sometag]this is a bit of text[/sometag]";
  let substitution = "$1";
  
  // result will be a String with the substituted value
  let result = regex.replace_all(string, substitution);
  
  println!("{}", result);
}