use strict;
my $str = '[sometag] here is more text
it spans more than one line [/sometag]
[sometag]this is a bit of text[/sometag]';
my $regex = qr/(?s)\[sometag\](.*?)\[\/sometag\]/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";