$re = '/(?s)\[sometag\](.*?)\[\/sometag\]/m';
$str = '[sometag] here is more text
it spans more than one line [/sometag]
[sometag]this is a bit of text[/sometag]';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;