using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\\])(fun)";
string substitution = @"\1\\fun";
string input = @"Czterdzieści [tex]fun{4}\fun{5}fun{6}[/tex] lat minęło";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}