import re
regex = re.compile(r"([^\\])(fun)", flags=re.MULTILINE)
test_str = "Czterdzieści [tex]fun{4}\\fun{5}fun{6}[/tex] lat minęło"
subst = "\\1\\\\fun"
result = regex.sub(subst, test_str)
if result:
print(result)