// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\\])(fun)").unwrap();
let string = "Czterdzieści [tex]fun{4}\\fun{5}fun{6}[/tex] lat minęło";
let substitution = "\\1\\\\fun";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}