$re = '/([^\\\\])(fun)/m';
$str = 'Czterdzieści [tex]fun{4}\\fun{5}fun{6}[/tex] lat minęło';
$subst = "\1\\fun";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;